summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAllan McRae <allan@archlinux.org>2016-09-25 19:10:03 +1000
committerAllan McRae <allan@archlinux.org>2016-10-10 10:37:21 +1000
commit05e1b8de1a96526c4e59745e7e4dc4a83a6383dd (patch)
tree562af4c78b9a17f757db811fbdd2d4b4bd071e5f /configure.ac
parent0d2ba870c96d1b4b3d5fabfabe303bc6b1c989fd (diff)
Remove internal md5 and sha2 implementations
The internal implementations for md5 and sha256 checksums have not been merged from upstream sources for a long time. Instead of us carrying copies of code from other projects, we should just support building against multiple libraries that provide such functionality. This patch removes the md5 and sha2 code (originally obtained from PolarSSL) from our repository. The configure script will now error unless at least one library supporting checksum generation is present, with the only library currently supported being openssl. It will be relatively simple for other such libraries (e.g. nettle) to be supported if anyone wishes to add them. Signed-off-by: Allan McRae <allan@archlinux.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c9515f2c..ae017d1d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -229,6 +229,11 @@ if test "x$with_openssl" != "xno"; then
fi
AM_CONDITIONAL(HAVE_LIBSSL, [test "$have_openssl" = "yes"])
+# Ensure one library for generating checksums is present
+if test "$have_openssl" != "yes"; then
+ AC_MSG_ERROR([*** no library for checksum generation found])
+fi
+
# Check for libcurl
have_libcurl=no
if test "x$with_libcurl" != "xno"; then